Wednesday, November 30, 2011

Installing Rational Application Developer on UBUNTU

Posted by Shiva Gouraram | Wednesday, November 30, 2011 | Category: , , , , |

Hi friends today i am going to explain how to install Rational Application Developer in UBUNTU(Linux)!

Follow the below steps to install




  1. Boot Ubuntu and log in.
  2. Open a command prompt and type the following to change your default shell from dash to bash:
    $ sudo dpkg-reconfigure dash
  3. Download and install the following debian package: http://packages.ubuntu.com/jaunty/libs/libstdc++5 - as RAD requires this and Ubuntu 10.04 ships only with a newer version.
  4. Insert RAD Setup Disk and run the following commands (launchpad.sh complains if you're not root):
    $ cd /media/rad_bundle_disk1
    $ sudo ./launchpad.sh
  5. Select "Install IBM Rational Application Developer for WebSphere Software".  Follow the prompts to install IBM Installation Manager and wait for it to restart.
  6. Select "Install IBM Rational Application Developer for WebSphere Software" (again!).
  7. Close the launchpad/Firefox window.  Either close your Terminal window (from Step 4) or cd out of /media/rad_bundle_disk1.  This allows the currently mounted CD to be unmounted by Ubuntu later when you need to change discs.
  8. Go back to IBM Installation Manager and select Install.  Update IBM Installation Manager if prompted.
  9. Select RAD7.5 and WebSphere 7.0 test environment, agree to the license, Click through and accept the default installation components.  (Personally, I disable administrative security on the profile).
  10. The installer will trundle away for an hour or so.  Click Finish when done.
  11. You're getting there...  Create the following script (/opt/IBM/SDP/launchEclipse.sh) for launching RAD as a lot of people have had troubles with this GDK_NATIVE_WINDOWS setting:
    #!/bin/sh
    export GDK_NATIVE_WINDOWS=true
    /opt/IBM/SDP/eclipse
    Set this script to executable:
    $ sudo chmod 755 /opt/IBM/SDP/launchEclipse.sh
  12. RAD/eclipse has been installed as root, and (for me anyway) it didn't put the IBM InstallationManager or RAD in the Ubuntu Applications menu.  So I created my own Application Launchers:

    Name: RAD7.5
    Command: /opt/IBM/SDP/launchEclipse.sh
    Icon: /opt/IBM/SDP/rad/RAD_v7_16.xpm

    Name: IBM Installation Manager
    Command: gksudo /opt/IBM/InstallationManager/eclipse/launcher
    Icon: /opt/IBM/InstallationManager/eclipse/documentation/IIM_32.xpm
  13. Before launching I also needed to add the following line to /opt/IBM/SDP/eclipse.ini, to fix an issue where eclipse will crash on the Welcome screen for a new workspace:
    -Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib/xulrunner
  14. If you want to run RAD *not* as root, you'll need to add write permissions to the following directory so RAD can interact with your WAS test environment profile (which is only writable by root as this is the user we used to install RAD):
    $ sudo chmod -R 777 /opt/IBM/SDP/runtimes/base_v7/profiles
That's it!  You should now be able to run RAD from your Application Launcher.

Share/Bookmark

Currently have 15 comments:

  1. unable to download package from http://packages.ubuntu.com/jaunty/libs/libstdc++5 as it says error.............What to do???...plz help....

  2. Once check whether other packages are being downloaded or not....any problem with network or else logged in an super user???or any permission problems!

  3. try this in place of that...
    http://packages.debian.org/squeeze/libstdc++5

  4. how to download http://packages.debian.org/squeeze/libstdc++5 this..explain the steps..

  5. click on this link you will get a .deb file downloaded just install it directly by double clicking....

    http://ftp.us.debian.org/debian/pool/main/g/gcc-3.3/libstdc++5_3.3.6-20_i386.deb

  6. Sir i have installed RSA 7.5 in ubuntu 12.04 64 bit and its server is working fine.
    But internel web browser is not working
    plz help
    thank you.x

  7. RSA???RSA is modelling tool...development tool is RAD...!

  8. RSA 7.5 have all the features of rad ..its working fine in win 7 but not in ubuntu :(

  9. see all these are built on eclipse...by default RAS is a modelling tool...but we caqn extend it further....so..if u want to use RAS as RAD...u have to install plugins..

  10. now i know what was ta problem i was using rsa 7.0(rad 7.0) that doesnot support mozilla firefox latest versions and ubuntu doesnt support previous vesion so thats why web browser is not running in rad .
    can u please mail me license key of rad 7.5 so that i will download the trail and use it.
    sumeet.1991@gmail.com
    thankyou

  11. This comment has been removed by the author.

  12. RAD is free...but when u install RAD u uncheck the installation of RFT...because RFT is not free...!

  13. it says launchpad not found any solution???

  14. it says launchpad not found any solution???


Leave a Reply

Subscribe